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BECOME BETA USER bit.ly/testdeeplite

WE USE AI TO MAKE OTHER AI FASTER, SMALLER 
AND MORE POWER EFFICIENT

Automatically compress SOTA models like MobileNet to <200KB with 

little to no drop in accuracy for inference on resource-limited MCUs

Reduce model optimization trial & error from weeks to days using 

Deeplite's design space exploration

Deploy more models to your device without sacrificing performance or 

battery life with our easy-to-use software
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TinyML for all developers

www.edgeimpulse.com

Test

Edge Device Impulse

Dataset

Embedded and edge 

compute deployment 

options

Acquire valuable 

training data securely

Test impulse with 

real-time device 

data flows

Enrich data and train 

ML algorithms

Real sensors in real time

Open source SDK

https://www.edgeimpulse.com/


Maxim Integrated: Enabling Edge Intelligence
Sensors and Signal Conditioning

Health sensors measure PPG and ECG signals 
critical to understanding vital signs. Signal chain 
products enable measuring even the most 
sensitive signals. 

Low Power Cortex M4 Micros

Large (3MB flash + 1MB SRAM) and small (256KB 
flash + 96KB SRAM, 1.6mm x 1.6mm) Cortex M4 
microcontrollers enable algorithms and neural 
networks to run at wearable power levels.

Advanced AI Acceleration IC

The new MAX78000 implements AI inferences at 
low energy levels, enabling complex audio and 
video inferencing to run on small batteries. Now 
the edge can see and hear like never before.

www.maximintegrated.com/MAX78000 www.maximintegrated.com/microcontroller
s

www.maximintegrated.com/sensor
s

https://www.maximintegrated.com/en/products/microcontrollers/MAX78000.html
https://www.maximintegrated.com/en/products/microcontrollers.html
https://www.maximintegrated.com/en/products/sensors.html


Qeexo AutoML

▪ Supports 17 ML methods: 

▪ Multi-class algorithms: GBM, XGBoost, Random 

Forest, Logistic Regression, Gaussian Naive Bayes, 

Decision Tree, Polynomial SVM, RBF SVM, SVM, CNN, 

RNN, CRNN, ANN

▪ Single-class algorithms: Local Outlier Factor, One 

Class SVM, One Class Random Forest, Isolation Forest

▪ Labels, records, validates, and visualizes time-series 

sensor data

▪ On-device inference optimized for low latency, low power 

consumption, and small memory footprint applications

▪ Supports Arm® Cortex™- M0 to M4 class MCUs

Key Features End-to-End Machine Learning Platform

Automated Machine Learning Platform that builds tinyML solutions for the Edge using sensor data

▪ Industrial Predictive 
Maintenance

▪ Smart Home

▪ Wearables

▪ Automotive

▪ Mobile

▪ IoT

Target Markets/Applications

For more information, visit: www.qeexo.com





SynSense builds sensing and inference hardware for ultra-

low-power (sub-mW) embedded, mobile and edge devices. 

We design systems for real-time always-on smart sensing, 

for audio, vision, IMUs, bio-signals and more.

https://SynSense.ai



Successful tinyML Summit 2021:
www.youtube.com/tinyML with 150+ videos

tinyML Summit-2022, January 24-26, Silicon Valley, CA

http://www.youtube.com/tinyML


June 7-10, 2021 (virtual, but LIVE)
Deadline for abstracts: May 1

Sponsorships are being accepted: sponsorships@tinyML.org

mailto:sponsorships@tinyML.org


Next tinyML Talks

Date Presenter Topic / Title

Tuesday,
April 27

Michael Jo and Xingheng Lin
Rose-Hulman Institute of Technology

Train-by-weight (TBW): Accelerated Deep 

Learning by Data Dimensionality Reduction

Webcast start time is 8 am Pacific time

Please contact talks@tinyml.org if you are interested in presenting

mailto:talks@tinyml.org


Local UK Committee



Reminders

youtube.com/tinyml

Slides & Videos will be posted tomorrow

tinyml.org/forums

Please use the Q&A window for your questions



Massimo Banzi
Massimo Banzi is the co-founder of the Arduino project. He is an 
Interaction Designer, Educator and Open Source Hardware advocate. He 
has worked as a consultant for clients such as: Prada, Artemide, Persol, 
Whirlpool, V&A Museum and Adidas. Massimo started the first FabLab in 
Italy which led to the creation of Officine Arduino, a FabLab/Makerspace 
based in Torino. He spent 4 years at the Interaction Design Institue Ivrea as 
Associate Professor. Massimo has taught workshops and has been a guest 
speaker at institutions allover the world. Before joining IDII he was CTO for 
the Seat Ventures incubator. He spent many years working as a software 
architect, both in Milan and London, on projects for clients like Italia 
Online, Sapient, Labour Party, BT, MCI WorldCom, SmithKlineBeecham, 
Storagetek, BSkyB and boo.com. Massimo is also the author of “Getting 
Started with Arduino” published by O’Reilly. He is a regular contributor to 
the Italian edition of Wired Magazine and Che Futuro, an online magazine 
about innovation. He currently teaches Interaction Design at SUPSI Lugano 
in the south of Switzerland and is a visiting professor at CIID in Copenhagen.
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TinyML with Arduino
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Introduction
In this talk we walk through some examples of TinyML on 
Arduino devices to show how simple it is to build working 
examples of ML with minimal coding using three different 
platforms compatible with Arduino.
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Enabling anyone 
to innovate by 
making complex 
technologies
simple to use.

Arduino
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29M+ Users/Year on arduino.cc
900K+ Arduino Forum Users
17M+ IDE downloads/year 
1.2M+ Users of Arduino Create Cloud
4000+ Libraries Available for Arduino

923K 302K                               408K
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Easy for 
Beginners, 
Fast for 
professionals

Arduino Today



> RIGHT CLICK ON IMAGE
> REPLACE IMAGE
> UPLOAD FROM COMPUTER /

DRIVE /
WEB URL

(PLEASE REMEMBER TO KEEP THE LEFT-SIDE WHITE GRID ON TOP)

6

Arduino Hardware
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Arduino Nano 
BLE Sense

● Nano form factor
● nRF52840 Arm Cortex M4f @ 

64MHz
● 1MByte Flash
● 256Kb Ram
● Bluetooth 5
● Sensors: IMU, Microphone, 

Gesture, Light, Proximity, 
Pressure, Temperature , Humidity
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Tiny Machine 
Learning Kit
• VGA Camera and Nano BLE Sense
• Used for the EdX course on TinyML





10https://www.edx.org/professional-certificate/harvardx-tiny-machine-learning
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Portenta H7

● Portenta form factor
● Dual core 

○ Arm Cortex M7@480MHz
○ Arm Cortex M4@240MHz

● up to 64 MByte SDRAM
● up to 128 MByte QSPI Flash
● Common Criteria Crypto
● WiFi b/g/n 65Mbps + BT 5.1
● 100Mbit Ethernet
● CAN
● USB-C with DisplayPort output
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Portenta Vision 
Shield

● Portenta form factor
● Low power cameras

○ Himax HM-01B0
○ Himax HM-0360

● Dual microphone (beamforming)
● Ethernet
● Lora
● SD Card
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TinyML on Arduino
Tensorflow Lite Micro

Title
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171717Arduino IDE 2.0 Beta



181818OpenMV IDE
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Examples
Arduino Tiny ML
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TinyML on Arduino
Tensorflow Lite Micro

TensorFlow Lite for Microcontrollers / Gesture Recognition
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We’re going to use the code provided here:
https://github.com/arduino/ArduinoTensorFlowLiteTutorials/tree/master/GestureToEmoji

Gesture Recognition

https://github.com/arduino/ArduinoTensorFlowLiteTutorials/tree/master/GestureToEmoji


232323TensorFlow Lite for Microcontrollers / Gesture Recognition

Visualize the IMU Data
• Open ArduinoSketches/IMU_Capture/IMU_Capture.ino in the 

Arduino IDE.
• Compile the sketch and upload it to the board: Sketch -> Upload
• Open the Serial Monitor: Tools -> Serial Monitor
• Press the button, IMU data will be captured and outputted for 1 second
• Close the Serial Monitor window
• Open the Serial Plotter: Tools -> Serial Plotter
• Press the button, and perform a gesture
• You'll see a graph of the data capture
• Repeat capturing various gestures to get a sense of what the training 

data will look like
• Close the Serial Plotter



242424TensorFlow Lite for Microcontrollers / Gesture Recognition



252525TensorFlow Lite for Microcontrollers / Gesture Recognition



262626TensorFlow Lite for Microcontrollers / Gesture Recognition



272727TensorFlow Lite for Microcontrollers / Gesture Recognition

Gather Training Data
• Press the reset button on the board
• Open the Serial Monitor: Tools -> Serial Monitor
• Make a punch gesture with the board in your hand - you should see 

the sensor data log in the Serial Monitor
• Repeat 10 times to gather more data
• Copy and paste the data from the serial output to new text file called 

punch.csv using your favorite text editor
• Close the Serial Monitor
• Press the reset button on the board
• Open the Serial Monitor: Tools -> Serial Monitor
• Make a flex gesture with the board in your hand
• Repeat 10 times
• Copy and paste the serial output to new text file flex.csv using your 

favorite text editor
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292929TensorFlow Lite for Microcontrollers / Gesture Recognition

Machine Learning 
• Go to this colab:
• https://colab.research.google.com/github/arduino/ArduinoTe

nsorFlowLiteTutorials/blob/master/GestureToEmoji/arduino_t
inyml_workshop.ipynb

• Drag punch.csv and flex.csv files from your computer to the 
tab to upload them into colab.

• Follow the instructions on the Notebook and you’ll end up with 
“model.h” file you can import into arduino



303030TensorFlow Lite for Microcontrollers / Gesture Recognition

Classifying IMU Data
• Open ArduinoSketches/IMU_Classifier/IMU_Classifier.ino in the 

Arduino IDE.
• Switch to the model.h tab
• Replace the contents of model.h with the version you 

downloaded from Colab
• Upload the sketch: Sketch -> Upload
• Open the Serial Monitor: Tools -> Serial Monitor
• Press the button, and perform a gesture
• The confidence of each gesture will be printed to the Serial 

Monitor (0 -> low confidence, 1 -> high confidence)



313131TensorFlow Lite for Microcontrollers / Gesture Recognition



323232TensorFlow Lite for Microcontrollers / Gesture Recognition

Gesture Controlled USB Emoji Keyboard
• The Emoji_Button example, ArduinoSketchs/Emoji_Button/Emoji_Button.ino, shows how 

to create a USB keyboard that prints and emoji character. (This only works on Linux and 
macos, so if you're running Windows, find a friend to work on this exercise.)

• Try combining the Emoji_Button example with the IMU_Classifier sketch to create an 
gesture controlled emoji keyboard. 👊
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343434OpenMV / Tensorflow / Portenta Vision Shield / Image Recognition
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REQUIRED HARDWARE AND SOFTWARE
• Portenta H7 board
• Portenta Vision Shield - LoRa or Portenta Vision Shield -

Ethernet
• USB-C cable (either USB-A to USB-C or USB-C to USB-C)
• An Edge Impulse account for training the ML model
• Fruits (or other objects) to create the classification model 
🍏🍌🍐



363636



373737



383838



393939



404040



414141



424242



434343



444444



454545



464646



474747



484848Portenta Vision Shield / Image Classification

https://www.arduino.cc/pro/tutorials/portenta-h7/vs-openmv-ml



494949Portenta Vision Shield / Person Detection

https://bit.ly/portenta_person_detection



505050Keyword Spotting / https://docs.edgeimpulse.com/docs/responding-to-your-voice



515151Qeexo / https://github.com/qeexo/Qeexo_AutoML_Arduino_Nano33BLE_pub



That’s a wrap,
Thank you!

Massimo Banzi

askmassimo@arduino.cc



Copyright Notice

This presentation in this publication was presented as a tinyML® Talks webcast. The content reflects the 
opinion of the author(s) and their respective companies. The inclusion of presentations in this 
publication does not constitute an endorsement by tinyML Foundation or the sponsors.

There is no copyright protection claimed by this publication. However, each presentation is the work of 
the authors and their respective companies and may contain copyrighted material. As such, it is strongly 
encouraged that any use reflect proper acknowledgement to the appropriate source. Any questions 
regarding the use of any materials presented should be directed to the author(s) or their companies.

tinyML is a registered trademark of the tinyML Foundation.

www.tinyML.org




